Frequently Asked Question

Can I upgrade to the latest ProcessVue Guardian software if I am using an older version of Windows?
Last Updated 3 months ago

Yes, you can; but you may have to update or install some Windows files in addition to upgrading the ProcessVue Guardian software.

Beginning with ProcessVue Guardian v1.8.172; the Web App requires Microsoft’s .NET framework v4.7.1 to be installed, before the ProcessVue Guardian software can be upgraded or installed.

Older versions of Windows, such as Server 2008 R2 may not have the correct version of .NET framework installed.

During the ProcessVue Guardian Web App installation process, you will be informed if you need to upgrade the .NET framework. The ProcessVue Guardian Web App installation process will fail, but this will NOT affect the data securely stored in your Master Database.

If you need to install .NET framework v4.7.1, it is advisable to ensure you have a minimum of 1.5Gb of free disk space. Without sufficient free space, the .NET framework installation will fail.

You will also need to install a trusted certificate prior to installing the Microsoft .NET framework upgrade.

The files you require are available from our ftp server, in the same location you have downloaded the ProcessVue Guardian Web App and Configurator from.

The installation process is as follows:
  • Uninstall the current versions of ProcessVue Guardian Web App and Configuration
  • Install ProcessVue Guardian Configurator
  • Upgrade your database using the Configurator
  • Install ProcessVue Guardian Web App

If no errors occur during the ProcessVue Guardian Web App installation, you can now work normally.

If the ProcessVue Guardian Web App install process finds .NET framework v4.7.1 to be missing, it will fail. You will need to:
  • Ensure you have > 1.5Gb of free disk space
  • Install the trusted certificate
  • Install .NET framework v4.7.1
  • Install ProcessVue Guardian Web App
You should now be able to use ProcessVue Guardian Web App normally, however; on some older versions of Windows, you may see an error page when attempting to load ProcessVue Guardian.

If you see the error:

Server Error in ‘/Guardian’ Application

Cannot load a reference assembly for execution

You may need to delete the dll file “System.IO.Compression.ZipFile.dll” from the “C:\inetpub\wwwroot\ProcessVue\Guardian\bin” directory.

ProcessVue Guardian Web App should now work correctly.

We recommend that you use the latest version of Google Chrome Web Browser, or Internet Explorer 11, if Chrome is not an option.

Please Wait!

Please wait... it will take a second!